[Bug 15497] New: WineD3D_ChoosePixelFormat errors when starting game

classic Classic list List threaded Threaded
27 messages Options
12
Reply | Threaded
Open this post in threaded view
|

[Bug 15497] New: WineD3D_ChoosePixelFormat errors when starting game

Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497

           Summary: WineD3D_ChoosePixelFormat errors when starting game
           Product: Wine
           Version: 1.1.5
          Platform: PC
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: directx-d3d
        AssignedTo: [hidden email]
        ReportedBy: [hidden email]


Created an attachment (id=16423)
 --> (http://bugs.winehq.org/attachment.cgi?id=16423)
Log of the crash

When I fire up Medieval Total War (the original, not the new one), using the
option to bypass movies, wine crashes with what appear to be Direct3D related
errors.


--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] WineD3D_ChoosePixelFormat errors when starting game

Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497





--- Comment #1 from Michael McDermott <[hidden email]>  2008-10-02 13:57:47 ---
Created an attachment (id=16424)
 --> (http://bugs.winehq.org/attachment.cgi?id=16424)
glxinfo for the machine

This is the output of running the glxinfo command. I am running NVidia's
drivers on Ubuntu 8.04. nvidia-settings lists the GPU as a GeForce 7000M.
Running in 16 bit color depth, because the app crashed trying to lower the
depth.


--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497


Roderick Colenbrander <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|WineD3D_ChoosePixelFormat   |Medieval total war crash
                   |errors when starting game   |




--- Comment #2 from Roderick Colenbrander <[hidden email]>  2008-10-02 14:01:43 ---
You can ignore WineD3D_ChoosePixelFormat as the fixme isn't bad at all. Based
on the info it can't even be said whether the crash is in d3d or not. You could
try running it using WINEDEBUG=+d3d,+d3d_surface,+d3d_shader,+d3d_texture,+seh
wine appname.exe > log


--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497


Michael McDermott <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #16423|0                           |1
        is obsolete|                            |




--- Comment #3 from Michael McDermott <[hidden email]>  2008-10-02 14:14:01 ---
Created an attachment (id=16425)
 --> (http://bugs.winehq.org/attachment.cgi?id=16425)
new crash log

This is the result of running

WINEDEBUG=+d3d,+d3d_surface,+d3d_shader,+d3d_texture,+seh wine Medieval_TW.exe
nm &> /tmp/wine3.log


--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497





--- Comment #4 from Michael McDermott <[hidden email]>  2008-10-02 20:29:41 ---
(In reply to comment #2)
> You can ignore WineD3D_ChoosePixelFormat as the fixme isn't bad at all. Based
> on the info it can't even be said whether the crash is in d3d or not. You could
> try running it using WINEDEBUG=+d3d,+d3d_surface,+d3d_shader,+d3d_texture,+seh
> wine appname.exe > log
>

Forgot to reply in the last message.


--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497


Vitaliy Margolen <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #16423|application/octet-stream    |text/plain
          mime type|                            |




--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497


Vitaliy Margolen <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #16424|application/octet-stream    |text/plain
          mime type|                            |




--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497





--- Comment #5 from Bernhard Rohrer <[hidden email]>  2008-11-05 13:54:06 ---
Created an attachment (id=17096)
 --> (http://bugs.winehq.org/attachment.cgi?id=17096)
MTW II d3d crash log


--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497


Bernhard Rohrer <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #17096|application/octet-stream    |text/plain
          mime type|                            |




--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497


Bernhard Rohrer <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]




--- Comment #6 from Bernhard Rohrer <[hidden email]>  2008-11-05 13:55:49 ---
I just uploaded a crash log. having the same issue with 1.1.7 on AMD64.
crashlog has the requested parameters set


--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497


KhaaL <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |NEW
     Ever Confirmed|0                           |1




--- Comment #7 from KhaaL <[hidden email]>  2009-01-12 11:03:52 ---
*** This bug has been confirmed by popular vote. ***


--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497


higuita <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]




--- Comment #8 from higuita <[hidden email]>  2009-03-10 21:08:17 ---
this seems related with medieval 2 total war, not the original medieval total
war, so its better to correct the summary


--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497





--- Comment #9 from Michael McDermott <[hidden email]>  2009-03-10 21:30:33 ---
(In reply to comment #8)
> this seems related with medieval 2 total war, not the original medieval total
> war, so its better to correct the summary
>

Hi,

I originally posted this bug and the logs I posted are from running the
original MTW, not MTW II. Apparently, the same bug manifests itself on both,
though.


--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497





--- Comment #10 from Vitaliy Margolen <[hidden email]>  2009-03-10 22:46:51 ---
*** Bug 17675 has been marked as a duplicate of this bug. ***


--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497





--- Comment #11 from Austin English <[hidden email]>  2009-09-08 11:40:06 ---
Is this still an issue in current (1.1.29 or newer) wine?

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497





--- Comment #12 from Michael McDermott <[hidden email]>  2009-09-09 21:17:27 ---
(In reply to comment #11)
> Is this still an issue in current (1.1.29 or newer) wine?

On Wine 1.1.29, running on Ubuntu 9.04, I still get the same result on a fresh
install.

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497

--- Comment #13 from Austin English <[hidden email]> 2010-12-20 21:48:51 CST ---
Does the demo have the same problem?
http://download.cnet.com/Medieval-Total-War-demo/3000-7483_4-10246017.html

is this still an issue in current (1.3.9 or newer) wine?

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497

--- Comment #14 from Michael McDermott <[hidden email]> 2011-01-08 13:59:19 CST ---
Created an attachment (id=32778)
 --> (http://bugs.winehq.org/attachment.cgi?id=32778)
Install attempt log

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497

--- Comment #15 from Michael McDermott <[hidden email]> 2011-01-08 14:00:38 CST ---
(In reply to comment #13)
> Does the demo have the same problem?
> http://download.cnet.com/Medieval-Total-War-demo/3000-7483_4-10246017.html
>
> is this still an issue in current (1.3.9 or newer) wine?

Using Wine 1.3.9, the installer fails. My previous message includes the log.

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 15497] Medieval total war crash

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
http://bugs.winehq.org/show_bug.cgi?id=15497

--- Comment #16 from joaopa <[hidden email]> 2012-05-13 03:55:52 CDT ---
Created attachment 40150
  --> http://bugs.winehq.org/attachment.cgi?id=40150
backtrace with amstream channel enabled

I managed to install the demo by using winedbg. After the game crashes in
amstream.

Using a native amstream fixes the bug.

Can an administrator change the component to AMSTREAM ?

--
Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.


12