[Bug 43164] New: World of Warships latest update (0.6.6) results in a critical error on Startup

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 43164] New: World of Warships latest update (0.6.6) results in a critical error on Startup

Wine - Bugs mailing list
https://bugs.winehq.org/show_bug.cgi?id=43164

            Bug ID: 43164
           Summary: World of Warships latest update (0.6.6) results in a
                    critical error on Startup
           Product: Wine
           Version: 2.10
          Hardware: x86
                OS: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: -unknown
          Assignee: [hidden email]
          Reporter: [hidden email]
      Distribution: ---

Created attachment 58419
  --> https://bugs.winehq.org/attachment.cgi?id=58419
World Of Warships Error Message

Hello everyone,

this might be related to 41314 and 38233 but I am having trouble of getting the
latest version of "World of Warships 0.6.6" to run. I am attaching a screenshot
of the error message as well as console output.

Installation was done in a fresh prefix with the European installer

$ sha256sum WoWS_internet_install_eu.exe
c59d3ca1b535c6315a71ef2eda045ccc2f8b207183ef4638f66b45c72d66430e
WoWS_internet_install_eu.exe

Report for the AppDB for this latest version has also been written.

Can you take a look into this please?

--
Do not reply to this email, post in Bugzilla using the
above URL to reply.
You are receiving this mail because:
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 43164] World of Warships latest update (0.6.6) results in a critical error on Startup

Wine - Bugs mailing list
https://bugs.winehq.org/show_bug.cgi?id=43164

Maik Wagner <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #1 from Maik Wagner <[hidden email]> ---
Created attachment 58420
  --> https://bugs.winehq.org/attachment.cgi?id=58420
World Of Warships Console Output wine 2.10

--
Do not reply to this email, post in Bugzilla using the
above URL to reply.
You are receiving this mail because:
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 43164] World of Warships latest update (0.6.6) results in a critical error on Startup

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
https://bugs.winehq.org/show_bug.cgi?id=43164

Maik Wagner <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                URL|                            |http://dl-wows-gc.wargaming
                   |                            |.net/eu/files/ilcClx1YzB/Wo
                   |                            |WS_internet_install_eu.exe

--
Do not reply to this email, post in Bugzilla using the
above URL to reply.
You are receiving this mail because:
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 43164] World of Warships latest update (0.6.6) results in a critical error on Startup

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
https://bugs.winehq.org/show_bug.cgi?id=43164

Maik Wagner <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
       Distribution|---                         |SUSE

--
Do not reply to this email, post in Bugzilla using the
above URL to reply.
You are receiving this mail because:
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 43164] World of Warships latest update (0.6.6) results in a critical error on Startup

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
https://bugs.winehq.org/show_bug.cgi?id=43164

Thomas Kühlke <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #2 from Thomas Kühlke <[hidden email]> ---
Created attachment 58427
  --> https://bugs.winehq.org/attachment.cgi?id=58427
Same result as Maik Wagners

Please check this up, thx!

--
Do not reply to this email, post in Bugzilla using the
above URL to reply.
You are receiving this mail because:
You are watching all bug changes.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 43164] World of Warships latest update (0.6.6) results in a critical error on Startup

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
https://bugs.winehq.org/show_bug.cgi?id=43164

Anastasius Focht <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]
           Keywords|                            |download

--- Comment #3 from Anastasius Focht <[hidden email]> ---
Hello folks,

I can't reproduce the crash, works fine here. I play a couple of matches daily
so I would have immediately noticed if something got broken after a client
update.

Versions tested:

* Wine 2.10 (low framerate, 15-20 fps on NVIDIA blob, not used for actual
gameplay)
* Wine 2.10 with CSMT enabled (low framerate, 12-18 fps with random jumps to 55
fps which seem outliers)
* Wine-Staging 2.5 CSMT (framerate doubled to stable 35-40 fps on NVIDIA blob
-> best performance, used for actual gameplay)
* Wine-Staging later versions are not really usable for this, they regressed in
various aspects (CSMT lower framerate, fullscreen windowed mode broken etc.),
didn't bother to dissect yet

No native overrides.

I have a 64-bit WINEPREFIX with the game constantly updated since the public
release, ca. 1,5 years ago, after CBT. The game itself is 32-bit.

I even installed the client v0.6.6.0 into a new WINEPREFIX (whopping 42 GB!).
No crash, still runs fine.

--- snip ---
$ du -sh Games/World_of_Warships/
42G    Games/World_of_Warships/
--- snip ---

Regards

--
Do not reply to this email, post in Bugzilla using the
above URL to reply.
You are receiving this mail because:
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 43164] World of Warships latest update (0.6.6) results in a critical error on Startup with Windows 7 Prefix

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
https://bugs.winehq.org/show_bug.cgi?id=43164

Maik Wagner <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|World of Warships latest    |World of Warships latest
                   |update (0.6.6) results in a |update (0.6.6) results in a
                   |critical error on Startup   |critical error on Startup
                   |                            |with Windows 7 Prefix

--- Comment #4 from Maik Wagner <[hidden email]> ---
Hello Anastasius,

thank you for following up on this. In the meantime I got notice that the game
itself does not work with prefix set to Windows 7 and settings need to be
modified to Windows 8.1 version. So it is definetely not "Platinum".

I modified my report in the AppDB and will also write a note about the changes
that need to be made.

With these settings the client starts up and I can also get to the Login
screen. Unfortunately my client is outdated and I would need to find a way to
bring it to the latest version.

I modified the title of the bug report a little to be more precise.

Again thanks again for checking this out.

Have a good day,


Maik

--
Do not reply to this email, post in Bugzilla using the
above URL to reply.
You are receiving this mail because:
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 43164] World of Warships latest update (0.6.6) results in a critical error on Startup with Windows 7 Prefix

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
https://bugs.winehq.org/show_bug.cgi?id=43164

--- Comment #5 from Anastasius Focht <[hidden email]> ---
Hello Maik,

--- quote ---
I got notice that the game itself does not work with prefix set to Windows 7
and settings need to be modified to Windows 8.1 version. So it is definetely
not "Platinum".
--- quote ---

I have no problems with the WINEPREFIX (64-bit) set to:

* 'Windows XP'
* 'Windows 7' etc.

the game client v0.6.6.1 starts fine for me in either mode.
Besides using my existing prefix I also tested with new/clean WINEPREFIX.

See also other people reporting successful test with Wine default setting:

https://forum.winehq.org/viewtopic.php?f=8&t=29007&view=previous#p111013

I find it worrying to read misleading tips in appdb ... but users should decide
what is best for them.

https://appdb.winehq.org/objectManager.php?sClass=version&iId=35369

--- quote ---
After patch 6.6, you need to set your windows version in winecfg to win8.1,
win2008 R2 or win10 to avoid a crash on start
--- quote ---

World of Warships minimum system requirement for OS is Windows 7 (x86/x64).
Why would people use Windows 8.x or even 10 setting? That doesn't make sense.

My guess would be people use a somewhat broken Wine build, broken Linux
host/gfx drivers, and/or operate on a broken WINEPREFIX.
I did not see any substantial proof yet that Wine is at fault here.
The attached console output is not meaningful.

I refrained myself from putting platinum test data/info into the game's appdb
section as this would likely cause pointless discussion "who is right" with the
maintainers.

Regards

--
Do not reply to this email, post in Bugzilla using the
above URL to reply.
You are receiving this mail because:
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 43164] World of Warships latest update (0.6.6) results in a critical error on Startup with Windows 7 Prefix

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
https://bugs.winehq.org/show_bug.cgi?id=43164

--- Comment #6 from Maik Wagner <[hidden email]> ---
Created attachment 58522
  --> https://bugs.winehq.org/attachment.cgi?id=58522
lspci Output of graphics chipsets.

Hello Anastasius,

thank you for your detailed reply. I am also assuming that this relates to
graphics chipsets and their drivers. I checked with Thomas which graphics
chipset he is using and guided him to get information on this. Info of both our
chipsets is attached.

He is using Intel apparently and I am using an AMD Radeon 8330 graphics
chipset. At least for me the switch to a Windows version higher than Windows 7
solved the issue for me and I can now get into the game.

Patching to 0.6.6.1 also worked fine.

--
Do not reply to this email, post in Bugzilla using the
above URL to reply.
You are receiving this mail because:
You are watching all bug changes.


Loading...