[Bug 44023] New: Cuphead hangs at black screen

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 44023] New: Cuphead hangs at black screen

Wine - Bugs mailing list
https://bugs.winehq.org/show_bug.cgi?id=44023

            Bug ID: 44023
           Summary: Cuphead hangs at black screen
           Product: Wine
           Version: 2.20
          Hardware: x86-64
                OS: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: -unknown
          Assignee: [hidden email]
          Reporter: [hidden email]
      Distribution: ---

Created attachment 59687
  --> https://bugs.winehq.org/attachment.cgi?id=59687
Cuphead Log

Cuphead starts but hangs before the MDHR logo can play

--
Do not reply to this email, post in Bugzilla using the
above URL to reply.
You are receiving this mail because:
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 44023] Cuphead hangs at black screen

Wine - Bugs mailing list
https://bugs.winehq.org/show_bug.cgi?id=44023

Fabian Maurer <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #1 from Fabian Maurer <[hidden email]> ---
> err:winediag:schan_imp_init Failed to load libgnutls, secure connections will not be available.

> err:module:load_builtin_dll failed to load .so lib for builtin L"XAudio2_0.dll": libopenal.so.1: cannot open shared object file: No such file or directory

Not sure if it's related, but you're missing two libraries.

--
Do not reply to this email, post in Bugzilla using the
above URL to reply.
You are receiving this mail because:
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 44023] Cuphead hangs at black screen

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
https://bugs.winehq.org/show_bug.cgi?id=44023

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #2 from [hidden email] ---
The same thing happens to me, on macOS, although it may be a different cause.

The only non-Wine errors Cuphead prints are:

Mono path[0] = 'C:/Program Files
(x86)/Steam/steamapps/common/Cuphead/Cuphead_Data/Managed'
Mono path[1] = 'C:/Program Files
(x86)/Steam/steamapps/common/Cuphead/Cuphead_Data/Mono'
Mono config path = 'C:/Program Files
(x86)/Steam/steamapps/common/Cuphead/Cuphead_Data/Mono/etc'
Player data archive not found at `C:/Program Files
(x86)/Steam/steamapps/common/Cuphead/Cuphead_Data/data.unity3d`, using local
filesystem


Which is strange, because Mono isn't installed.

--
Do not reply to this email, post in Bugzilla using the
above URL to reply.
You are receiving this mail because:
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 44023] Cuphead hangs at black screen

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
https://bugs.winehq.org/show_bug.cgi?id=44023

--- Comment #3 from Austin English <[hidden email]> ---
(In reply to alexchandel from comment #2)

> The same thing happens to me, on macOS, although it may be a different cause.
>
> The only non-Wine errors Cuphead prints are:
>
> Mono path[0] = 'C:/Program Files
> (x86)/Steam/steamapps/common/Cuphead/Cuphead_Data/Managed'
> Mono path[1] = 'C:/Program Files
> (x86)/Steam/steamapps/common/Cuphead/Cuphead_Data/Mono'
> Mono config path = 'C:/Program Files
> (x86)/Steam/steamapps/common/Cuphead/Cuphead_Data/Mono/etc'
> Player data archive not found at `C:/Program Files
> (x86)/Steam/steamapps/common/Cuphead/Cuphead_Data/data.unity3d`, using local
> filesystem
>
>
> Which is strange, because Mono isn't installed.

Unity3d uses Mono:
https://en.wikipedia.org/wiki/Mono_(software)#Software_developed_with_Mono

--
Do not reply to this email, post in Bugzilla using the
above URL to reply.
You are receiving this mail because:
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 44023] Cuphead hangs at black screen

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
https://bugs.winehq.org/show_bug.cgi?id=44023

--- Comment #4 from [hidden email] ---
(In reply to Austin English from comment #3)

> (In reply to alexchandel from comment #2)
> > The same thing happens to me, on macOS, although it may be a different cause.
> >
> > The only non-Wine errors Cuphead prints are:
> >
> > Mono path[0] = 'C:/Program Files
> > (x86)/Steam/steamapps/common/Cuphead/Cuphead_Data/Managed'
> > Mono path[1] = 'C:/Program Files
> > (x86)/Steam/steamapps/common/Cuphead/Cuphead_Data/Mono'
> > Mono config path = 'C:/Program Files
> > (x86)/Steam/steamapps/common/Cuphead/Cuphead_Data/Mono/etc'
> > Player data archive not found at `C:/Program Files
> > (x86)/Steam/steamapps/common/Cuphead/Cuphead_Data/data.unity3d`, using local
> > filesystem
> >
> >
> > Which is strange, because Mono isn't installed.
>
> Unity3d uses Mono:
> https://en.wikipedia.org/wiki/Mono_(software)#Software_developed_with_Mono

Ok. I found Wine errors as well:

fixme:ntdll:EtwEventRegister ({47a9201e-73b0-42ce-9821-7e134361bc6f},
0x3f006bd0, 0x3f043cf0, 0x3f043ce8) stub.
fixme:ntdll:EtwEventRegister ({58a9201e-73b0-42ce-9821-7e134361bc70},
0x3f006bd0, 0x3f043d28, 0x3f043d20) stub.
fixme:ntdll:EtwEventRegister ({3fa9201e-73b0-43fe-9821-7e145359bc6f},
0x3f006bd0, 0x3f043dd0, 0x3f043dc8) stub.
fixme:ntdll:EtwEventRegister ({1432afee-73b0-42ce-9821-7e134361b433},
0x3f006bd0, 0x3f043d60, 0x3f043d58) stub.
fixme:ntdll:EtwEventRegister ({4372afee-73b0-42ce-9821-7e134361b519},
0x3f006bd0, 0x3f043d98, 0x3f043d90) stub.
fixme:winsock:set_dont_fragment IP_DONTFRAGMENT for IPv4 not supported in this
platform
fixme:ver:GetCurrentPackageId (0x33e520 0x0): stub
fixme:process:ProcessIdToSessionId Unsupported for other processes.

But none of these seem particularly related to the (pixelated) black screen I
receive.

--
Do not reply to this email, post in Bugzilla using the
above URL to reply.
You are receiving this mail because:
You are watching all bug changes.


Reply | Threaded
Open this post in threaded view
|

[Bug 44023] Cuphead hangs at black screen

Wine - Bugs mailing list
In reply to this post by Wine - Bugs mailing list
https://bugs.winehq.org/show_bug.cgi?id=44023

--- Comment #5 from [hidden email] ---
Created attachment 59781
  --> https://bugs.winehq.org/attachment.cgi?id=59781
screenshot of Cuphead hang

Cuphead immediately displays this screen after launch (in which the static
animates for about a second, then freezes), then hangs forever.

--
Do not reply to this email, post in Bugzilla using the
above URL to reply.
You are receiving this mail because:
You are watching all bug changes.